View Single Post
  #1  
Old 06-29-2010, 03:51 PM
Merrick Graves Merrick Graves is offline
Old Goat
 
Join Date: Jan 2009
Location: Naches
Posts: 566
Default The First Time ever!!

Well after as many years as I been running trails I was for the first time ever unable to get the rig I was driving out of the woods and back home (so to speak).

I worked for the Cle Elum Ranger District last Sunday and we (my wife and I) went for a run to check the trail and snowline up the 4w301 (Gallagher Head). We made it to where the snow stopped us and turned around and came out of the trail ok. Decided to run up a spur road and check out things there when the Power Steering pump on the FS Jeep started growling. I checked the fluids and all were ok. The belt was tight. You could see a vibration of the PS pump as the engine idled. We headed down the road and went out via the gate rather than the trail. Continued down towards Salmon La Sac and by the time we got there the pump was growling and had a loud rattle to it. We continued on and the noise got louder and louder. Just as we entered Ronald you could hear a new even louder noise. At that point I gave up making it back to the station. Kim and I pulled into the parking lot of the "OLD #3" Bar and Grill. Not a bad place to be stranded except I am in uniform and can not enjoy the livations as I would of liked. OH WELL!!

I called for assistance and Mikki came with the dually and a vehicle trailer. We loaded the FS Jeep and headed back to the station. Upon arrivial as we were unloading the trailer the FS Jeep spit out the fan belt. That was the end of the pump. I was able to manuever the jeep into it's parking stall.

Figures it would be a government vehicle that ruined my record of never needing assistance to get back to where I started without a strap, hook or tariler.

irtDOG:Anybody got a good power steering pump for a 98 TJ with a 4 liter. Our budget can't afford this!!
Reply With Quote