Thread: WOW Rimrock Run
View Single Post
  #1  
Old 10-14-2009, 06:48 PM
dirk's Avatar
dirk dirk is offline
that WOHVA guy
 
Join Date: Jan 2009
Location: washington
Posts: 645
Default WOW Rimrock Run

A few folks from the Wheelers of Washington (WOW) made a run over to Rimrock last weekend.

Anthony headed over FRI night...he hadn't been to Rimrock since he was in high school. Danielle & I headed over SAT morning...this was her first time ever & my third time (my first time on the FS1000 road).



I never did see a sign for Bakeoven Flats, but I did see one for Grey Creek Campground...we pulled in to check it out & found Anthony coming out to see us.



Unloaded the rigs...



Our camp was right at the exit for the 621 trail...lot's of steep down hill only trails on this side of the ridge...



Anthony had a buddy coming down from Cle Elum, so we set up the banner to help him find camp...



Waited awhile for John to show up & decided to head up to higher ground for cell phone reception. We headed up FS1000 to the 640 trail. Made it up to the top of Blue Slide & ran into 10+ guys out of Morton. They were fixing a brake line before dropping back down the hill. I told them a little about our group & handed them a card. I asked if they ever went to Elbe...they were not big fans of mud :haha: Getting ready to go & we heard John calling on the CB. Dropped back down to the road & scooped up John.



After meeting up with John, we ran 640 to 640A to 640 to 638...found some snow on 638 & I was reminded how much sticky tires suck in the white stuff. Flogged our junk on the snow climbs. Anthony powered up without any issues. John & I stomped on the skinny pedal, but ended up winching part of the hill.

Made it to Blue Lake...



And John discovered a broken 3 link in the front...the upper link mount truss had ripped completely off the housing. Lucky for us...I was still packing my buddy's ready welder around with me (thank you casey) and we were able to fix the problem.









Sweet fabrication...welded a few wrenches & one bottle jack handle on for support :super:



Did I mention it was really cold...we were all pretty frozen by the time we were moving again. Weather report called for clear skies...high of 40 and overnight low of 20. The clouds never burned off & it was cold.

Bumped into some of the Morton crew again & headed off to find Short & Dirty Ridge (637). Drove past Short & Dirty, but turned around before we went too far. Dropped down into some nice snowy sections...found a nice off camber spot covered in snow. I drove across, slide down & had to winch back up...same story with John. Anthony spanked it (it became a common theme for the trip).

Made it down out of the snow & took in the beautiful views from Short & Dirty Ridge. Decided to drop all the way off the end, try to circle back up & drop down back into camp. We almost made it down off the ridge, when John lost a track bar axle mount. This time it was dark, really cold & we just wanted to get back to camp...pulled out the welder, lined things back up, burned some metal & added a few more wrenches for strength. It wasn't our best work

Drove the rig out under its own power & up the road back to camp...rolled into camp around 11'ish. John loaded up & headed back to Cle Elum.

We turned up the heat in Anthony's camper & thawed out Danielle...she was pretty miserable. Anthony let us crash in his camper...so we slept pretty warm. With an overnight low of 20...I wasn't looking forward to tenting it
__________________
Bryan Peterson
WOHVA | PNW4WDA
Reply With Quote