Go Back   Pacific Northwest Four Wheel Drive Association > Tool Bag > Garage
Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Garage Break it/Fix it

Reply
 
Thread Tools Display Modes
  #1  
Old 07-07-2009, 09:51 AM
Dogfather's Avatar
Dogfather Dogfather is offline
The One that Screws it up
 
Join Date: Jan 2005
Location: Rochester, WA
Posts: 1,866
Default C6 Behind a 6.9L Diesel ((Help))

Hey folks here is the Story

Trans went out so went to Scrapyard and bought a used one. 2 months later it started gushing fluid from the front of the trans.

Thought the worse so I went and picked up another. Had a kid install it and it immediately gushed fluid out the front.

When the kid pulled it back out he said he saw a crack in the Flex-Plate... Replaced that, and I finished the kids re-install. Gush from the front

Thinking he may have Damaged the seal I Pulled it, installed new Seal, and carefully re-installed it. Gush from the front.

Pulled it again thinking the cracked Flex-plate might have cracked the Torque converter I replaced it with the Original Tran Converter. Still gush from the front.

Pulled it again to Verify the Flex-Plate was installed properly? ( Only one way for Flex-Plate to go on.

This is where I am now Tranny on Jack looking for Suggestions as to what to check Next?????

Oh and by the way this is My Brothers truck in My Yard.
__________________
Edward Campbell
The Webmaster "Oops I did it.....My Bad"
Region 2 Director 2008-2010 Glad to help.
DogpoundOffroad
Reply With Quote
  #2  
Old 07-07-2009, 11:30 AM
EagleMark EagleMark is offline
Banned
 
Join Date: Jan 2009
Location: North Idaho
Posts: 432
Default

I hate when that happens...
Reply With Quote
  #3  
Old 07-14-2009, 07:45 AM
zukkev's Avatar
zukkev zukkev is offline
Dirt Napper....
 
Join Date: Jan 2009
Location: Bellingham
Posts: 460
Default

Bad pump to case seal, or crack in the front pump housing??? Stand the trans up in a 5 gal bucket or something to hold it up, and remove the pump... shouldn't be too difficult.
__________________
Dirt-Nappin' at its finest!!!
www.rrr4x4.com
Reply With Quote
  #4  
Old 07-14-2009, 07:46 AM
zukkev's Avatar
zukkev zukkev is offline
Dirt Napper....
 
Join Date: Jan 2009
Location: Bellingham
Posts: 460
Default

When you say 'out the front', is the leak coming from the dipstick tube maybe???
__________________
Dirt-Nappin' at its finest!!!
www.rrr4x4.com
Reply With Quote
  #5  
Old 07-14-2009, 07:58 AM
Dogfather's Avatar
Dogfather Dogfather is offline
The One that Screws it up
 
Join Date: Jan 2005
Location: Rochester, WA
Posts: 1,866
Default

as you watch the fluid come out it comes between the torque converter and bell housing.
you can not see any cracks in Pump, the strange part is two transmissions are doing the same thing. the one that we pulled out and the New (used) one we put in.
__________________
Edward Campbell
The Webmaster "Oops I did it.....My Bad"
Region 2 Director 2008-2010 Glad to help.
DogpoundOffroad
Reply With Quote
  #6  
Old 07-14-2009, 12:13 PM
zukkev's Avatar
zukkev zukkev is offline
Dirt Napper....
 
Join Date: Jan 2009
Location: Bellingham
Posts: 460
Default

Quote:
Originally Posted by Dogfather View Post
as you watch the fluid come out it comes between the torque converter and bell housing.
you can not see any cracks in Pump, the strange part is two transmissions are doing the same thing. the one that we pulled out and the New (used) one we put in.
could it be coincidence that the pump-to-housing seals are bad on both trannies??? or that the pump-to-converter seals are bad??? I'd be looking real close....install a dye into the ATF, run it & use a black light to locate the source of the leak...
__________________
Dirt-Nappin' at its finest!!!
www.rrr4x4.com
Reply With Quote
  #7  
Old 07-14-2009, 12:31 PM
jim putman's Avatar
jim putman jim putman is offline
Washington State Director
 
Join Date: Jan 2009
Location: puyallup wa.
Posts: 1,526
Default

using the same converter on both ? Maybe a crack in the converter
__________________
Member #40 Hombres jeep club
Region 2 landmatters chairman
Wa. State Director PNW4WDA
Reply With Quote
  #8  
Old 07-16-2009, 08:15 AM
Dogfather's Avatar
Dogfather Dogfather is offline
The One that Screws it up
 
Join Date: Jan 2005
Location: Rochester, WA
Posts: 1,866
Default

Quote:
Originally Posted by jim putman View Post
using the same converter on both ? Maybe a crack in the converter
Nope used the converter that came with the new one, then thinking something might have been wrong with it I tried one from the first tranny we pulled out. and still this leak
__________________
Edward Campbell
The Webmaster "Oops I did it.....My Bad"
Region 2 Director 2008-2010 Glad to help.
DogpoundOffroad
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -7. The time now is 02:23 AM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.